Home > Ax Technical > Dynamics Ax 2009 compatibilitywith .Net 4

Dynamics Ax 2009 compatibilitywith .Net 4

January 27, 2011 Leave a comment Go to comments

I was recently developing a class library application for Dynamics Ax 2009  on Visual studio 2010. When I tried adding it  to the reference node, Ax threw an error informing that it is not a valid .Net assembly.  I had to change the version to 3.5 in the build properties of the VS Project to generate a compatible dll. I’m not sure if .Net 4 is compatible with Ax2009 but made it a note here….

Here is some compatibility information from SE Team  SE Team – Compatibility testing results but it only says Ax2009 and .Net 4 can run side by side. So guys it is good to check your .Net versions and try before you absorb it in to ax when facing a similar error.

……….

Advertisements
  1. April 25, 2011 at 4:45 pm

    Yes Kryshna this can happen at times. When we faced a similar issue in one of our dev machine it had cropped up because of an expired Visual studio installation. I would suggest you to remove your .net framework and any expired VS editions. Now install .Net 3.5 and run ax2009. This should work.

  2. kryshna
    April 7, 2011 at 7:49 am

    i got an issue with .net frame work and ax 2009 running.
    when i try to upgrade my application, it doesmt work.
    I am not able to install any other additional instances

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: